Kuidas hankida vanade macOS-i versioonide installijad otse Apple'ilt

Apple teeb mingil põhjusel MacOS-i vanemate versioonide jaoks installijate leidmise üsna raskeks. Kuigi see on keeruline, on see siiski täiesti võimalik.

See võib olla eriti asjakohane teave hiljutise turvasertifikaadi aegumise tõttu oktoobris. Kuid me jõuame selle juurde natuke. Siin on see, mida peate teadma vana macOS-i installipildi leidmise kohta, miks neid võib vaja minna, ja mõned näpunäited nende edaspidiseks kogumiseks.

Miks vajate vanu macOS-i installijaid?

Vanu macOS-i installijaid saab kasutada mitmel eesmärgil, sealhulgas käivitatavate USB-draivide loomiseks.

On mitu põhjust, miks vanema macOS-i installiprogrammi hoidmine on hea mõte, kuid enamik neist on üsna tehnilised. Kui kuulute kategooriasse, kus vajate vana MacOS-i versiooni, teate seda. (Selles loendis võivad olla süsteemiadministraatorid, turvatöötajad, arendajad jne)

Kõige mittetehniline põhjus macOS-i vanema versiooni vajaduseks on lihtsalt vanema masina värskendamine. Mitte iga vabas looduses olev Mac ei ole võimeline töötama macOS Catalina.

Tegelikult, kui teil on eriti vana Mac, kes tolmu kogub, ja soovite seda värskendada, võib olla üsna keeruline leida MacOSi uusimat versiooni, mida see saaks käitada.

Võib juhtuda, et jätate selle versiooniga, mida see praegu töötab. Kuid enamikul juhtudel on eelistatum kasutada MacOS-i uuemat versiooni (või uusimat võimalikku versiooni).

Vana installeripilt on uskumatult mugav ka siis, kui usaldate 32-bitiseid rakendusi ja pole veel MacOS Catalina versioonile värskendatud.

Nagu me varem käsitlesime, saate Maci virtuaalse masina tegelikult seadistada virtualiseerimise rakenduse abil, näiteks VirtualBox. Näiteks saate MacOS Mojave virtuaalses masinas seadistada ja jätkata 32-bitiste rakenduste kasutamist - isegi kui teie host Mac töötab Catalinaga.

Miks see otse Apple'ilt hankida?

Aga oodake, võite öelda. Kuigi peaksite kaevama ja proovima leida Apple'i lingi vana macOS-i installiprogrammiga, kui leiate lihtsalt kolmanda osapoole veebisaidilt täiesti hea?

Ühesõnaga: kuna need kolmanda osapoole lingid pole ilmselt ohutud.

Seal on kahtlemata täiesti häid inimesi, kes avaldavad vanu macOS-i installiprogramme, millel pole mingit pahatahtlikku kavatsust. Häda on selles, et on raske - kui mitte võimatu - teada, kas nad langevad sellesse või halva näitleja laagrisse.

Seetõttu tasub loobuda mis tahes kolmanda osapoole allalaadimislingist ja teha täiendavaid jõupingutusi linkide otsimiseks otse Apple'ilt. Nii olete palju turvalisem igasuguse pahatahtliku tarkvara, nuhkvara või muude võimalike rünnakute eest.

Kuidas leida vanu macOS-i installijaid

Alates selle artikli kirjutamisest saate endiselt MacOS Mojave või High Sierra App Store'ist alla laadida.

Nagu me mainisime, on Apple juba pikka aega varjanud vanu macOS-i installipilte. Need on saadaval, neid pole lihtsalt väga lihtne leida.

Kui vanad installeripildid olid tehniliselt App Store'is, astus Apple sammud nende tegelikult peitmiseks, nii et neid ei olnud otsingu kaudu leitav.

Varem oli ainus viis nende juurde jõudmiseks järgida erinevates Apple'i tugidokumentatsioonides peidetud otselinke. Kuid Apple teatas hiljuti, et see muudab vanade macOS-i installijate võõrustamist.

Esmalt kontrollige Mac App Store'i

MacOS Mojave ja macOS High Sierra puhul puudutage Maci App Store'i avamiseks toodud linki ja kontrollige, kas need kaks versiooni on endiselt saadaval.

Kui ei, siis leiate siit otselinke, kus Apple'i saidid saavad alla laadida Sierra, High Sierra ja Mojave.

Kas juba värskendate macOS Catalinat või värskendate seda versioonile?

Vähemalt soovitame alla laadida Mojave installeri. See on tõenäoliselt kasulik paljude inimeste jaoks, alates 32-bitistele rakendustele tuginevatest kasutajatest kuni vanemate Macide kasutajateni, kes soovivad värskendada, kuid väldivad macOS Catalinat.

Kuidas saada installija vanemate macOS- ja OS X-versioonide jaoks

Kui Apple tõmbas Mac App Store'ist linke macOS Sierra, macOS El Capitan ja macOS Yosemite jaoks, on vajaliku macOS või Mac OS X versiooni leidmiseks veel mõned võimalused.

Külastage Apple'i toe põhilehte ja otsige

Lihtsaim viis on minna Apple'i tugiteenuste lehele ja seejärel otsida soovitud macOS-i või OS X-i versiooni.

Sõnastus on oluline, seega tippige välja „Kuidas uuendada (täitke vajalik MacOS- või OS X-versioon)

Minge Apple'i allalaadimise lehele

Kuigi paljud neist installijatest on veelgi sügavamal peidus, on nad endiselt Apple'i veebisaidi hämaras nurgas: allalaadimiste lehel.

Veelgi vanemad macOS-versioonid leiate Apple'i varjatud allalaadimiste lehelt.

Siit leiate tegelikult sama vanad macOS-versioonid kui Mac OS X Tiger alates 2005. aastast. Me ei tea, kas see töötab, kuid vajadusel on see olemas.

Enamiku inimeste jaoks on tõenäoliselt kõige kasulikumad MacOS-versioonid nagu Mojave, High Sierra ja Sierra, samuti OS X-i versioonid nagu Yosemite, El Capitan ja Sierra. Kui leht avaneb, kerige alla jaotiseni Allalaadimine ja otsige valikutKui vajate endiselt macOS / OS X-i, kasutage seda App Store'i linki.Selle viiba puudutamisel avaneb Mac App Store, et saaksite selle konkreetse versiooni alla laadida.

macOS-i versioonid

    OS X versioonid

      Mõned asjad, mida tasub tähele panna

      Enne vanade macOS-piltide allalaadimist või installimist peaksite meeles pidama mõnda asja.

      • Pidage kindlasti meeles parimaid tavasid. Kontrollige, milliseid macOS-i versioone teie vanem Mac saab käitada. Enne värskendamist varundage seade kindlasti - soovitavalt mitu korda.
      • Tagasi pole minna. Vanema versiooni peale saate installida macOS-i uuema versiooni. Kuid see ei toimi vastupidi. Vanemat macOS-i pole võimalik uuemale installida. Kui peate seda tegema, peate Maci täielikult pühkima ja installima vanema versiooni.
      • Lingid võivad muutuda. Kuigi Apple on teinud vanemad macOS-versioonid kättesaadavaks, pole mingit garantiid, et see ei tõmba lõpuks MacOS-i vanemat versiooni (või muudab nende leidmise veelgi raskemaks). Kui vajate installeripilte, tasub need kohe jätkata ja need alla laadida.
      • Kui teie Mac töötab OS X Mavericks ja üle selle. Võite uuemale versioonile üle minna macOS-ile, enne ei pea te oma OS X-i versiooni värskendama. Kui kasutate rakendust Lion (10.7) või Mountain Lion (10.8), peate kõigepealt täiendama versioonile El Capitan (10.11) ja seejärel värskendama macOS-ile.

      Miks vajate pärast 2019. aasta oktoobrit värskenduste jaoks uusi macOS-i installipilte?

      Nagu näete, aegus Apple'i viimane turvasertifikaat 24. oktoobril.

      Tõenäoliselt on palju inimesi, kes olid varem kogunud mitmeid macOS-i installiprogramme. Kahjuks, nagu me varem vihjasime, on need pildid nüüd kasutud.

      Veel 24. oktoobril 2019 aegusid paljude vanade MacOS-versioonide turvasertifikaadid. Sisuliselt tähendab see, et neid vanu macOS-i versioone enam ei käitata. See on häbi, kuid saate midagi teha.

      Kuigi vanad macOS-i installipildid on nüüd kasutud, on igal Apple'i 24. oktoobrist alla laaditud installipildil uued turvasertifikaadid.

      Õnneks on Apple uuendanud kõigi pakutavate vanade macOS-i installipiltide sertifikaate. Sertifikaadid aeguvad kahjuks uuesti. Tagurpidi on see, et nende kehtivusaeg lõpeb alles 2029. Nii et teil on aastakümne väärt MacOS-i installimise lõbus.

      (Märkus. MacOS-i installitud versioonid töötavad jätkuvalt hästi. Hätta jäävad ainult installijad.)

      Enne midagi installimist lahtiütlus

      Kõike seda öeldes tasub märkida, et enamik inimesi ei vaja vana macOS-i installiprogrammi varu. Tõenäoliselt ei pea nad isegi MacOS-i vanemale versioonile värskendama.

      Me ei soovita proovida oma igapäevast draiverit Maci installida ühtegi vana macOS-i versiooni, kui te tõesti seda ei vaja. Kui soovite tõesti uurida vana Maci versiooni, kasutage sekundaarset sülearvutit või virtuaalset masinat.

      Kui teie Mac suudab käitada macOS Catalina, soovitame tungivalt värskendada seda MacOS-i versiooni. (Kui te ei vaja 32-bitiseid rakendusi, peaksite sel juhul installima macOS Mojave.)

      Kui teie Mac ei toeta Catalinat ja te pole seda aastaid uuendanud, soovitame uurida, milliste MacOS-i versioonidega see ühildub, ja värskendada uusimatele.

      Kui teil on küsimusi või täiendavaid näpunäiteid, andke meile sellest teada allpool toodud kommentaarides.

      Lang L: none (rec-post)

      $config[zx-auto] not found$config[zx-overlay] not found